[Pharo-project] Fwd: Closure update from eliot
Begin forwarded message:
From: John M McIntosh <johnmci@smalltalkconsulting.com> Date: May 1, 2009 7:43:44 PM CEDT To: Eliot Miranda <eliot.miranda@gmail.com> Cc: Stéphane Ducasse <stephane.ducasse@inria.fr> Subject: Re: [Pharo-project] Closure update from eliot Reply-To: johnmci@smalltalkconsulting.com
Boo hiss, well that would work, but '12' is a magic number in this case the iteration over the collection was to *avoid* one-off useages of a magic number Well humpft.
Of course one off usages of a magic number is allowed... Since it's less typing..
On 1-May-09, at 10:31 AM, Eliot Miranda wrote:
I just used this in an updated Pharo0.1Core-10281cl.image
PseudoContext becomeUncompact. LargeNegativeInteger becomeCompact. Smalltalk compactClassesArray at: 12 put: nil. "Stomp on the obsolete Translated whatsit" BlockClosure becomeCompact
-- = = = = = ====================================================================== John M. McIntosh <johnmci@smalltalkconsulting.com> Twitter: squeaker68882 Corporate Smalltalk Consulting Ltd. http:// www.smalltalkconsulting.com = = = = = ======================================================================
participants (1)
-
Stéphane Ducasse