[Pharo-project] Fwd: Process stuck in 10156+OB?
marcus here it is Begin forwarded message:
From: John M McIntosh <johnmci@mac.com> Date: July 22, 2009 1:21:17 PM CEDT To: Stéphane Ducasse <stephane.ducasse@inria.fr> Subject: Fwd: [Pharo-project] Process stuck in 10156+OB? Reply-To: johnmci@smalltalkconsulting.com
Begin forwarded message:
From: John M McIntosh <johnmci@smalltalkconsulting.com> Date: January 26, 2009 7:30:23 PM GMT+01:00 To: Stéphane Ducasse <stephane.ducasse@inria.fr> Subject: Re: [Pharo-project] Process stuck in 10156+OB? Reply-To: johnmci@smalltalkconsulting.com
Ok, I think the test is attached, however you should change the name from JMMTest to something else.
like MacHostMenusTestCaseCharacterSubstitutions
On 20-Nov-08, at 1:27 PM, Stéphane Ducasse wrote:
john do you have a new version of the package since the method calculateShouldBeFrom:using: is missing
On Nov 20, 2008, at 12:03 AM, John M McIntosh wrote:
testCharacterChanging | testString item shouldBe resultingString where | #(';' '^' '!' '<' '/' '(' ) do: [:c | #('*' '* ' '* ' '**' '** ' '** ' ')' '*)' '* )' '* )' '**)' '** )' '** )' ')' '*)' '*X)' '*XX)' '**)' '**X)' '**XX)' '))' '*))' '*X))' '*XX))' '**))' '**X))' '**XX))' '(' '*(' '*X(' '*XX(' '**)' '**X(' '**XX(' '((' '*((' '*X((' '*XX((' '**((' '**X((' '**XX((' ) do: [:template | testString := template copyReplaceAll: '*' with: c. testString permutationsDo: [:mixedUp | item := mixedUp copy. shouldBe := self calculateShouldBeFrom: item using: c. resultingString := self modifySqueakMenu: item copy. self should: [shouldBe = resultingString]. (where := resultingString indexOf: $/) > 0 ifTrue: [self should: [(mixedUp at: where) = $(]. self should: [(mixedUp at: where+2) = $)]. self should: [(mixedUp at: where+1) asUppercase = (resultingString at: where+1)]]]]]
-- = = = = = = ===================================================================== John M. McIntosh <johnmci@smalltalkconsulting.com> Corporate Smalltalk Consulting Ltd. http://www.smalltalkconsulting.com = = = = = = =====================================================================
On 22.07.2009, at 09:23, Stéphane Ducasse wrote:
marcus here it is
Ok, I edited the fileout to make it compatible. The .st file attached to the bugreport now fixes the problem: http://code.google.com/p/pharo/issues/detail?id=977 This reminds me that we need to actually use the hostmenus and provide real menus... (the contents of the world menu) Marcus
Begin forwarded message:
From: John M McIntosh <johnmci@mac.com> Date: July 22, 2009 1:21:17 PM CEDT To: Stéphane Ducasse <stephane.ducasse@inria.fr> Subject: Fwd: [Pharo-project] Process stuck in 10156+OB? Reply-To: johnmci@smalltalkconsulting.com
Begin forwarded message:
From: John M McIntosh <johnmci@smalltalkconsulting.com> Date: January 26, 2009 7:30:23 PM GMT+01:00 To: Stéphane Ducasse <stephane.ducasse@inria.fr> Subject: Re: [Pharo-project] Process stuck in 10156+OB? Reply-To: johnmci@smalltalkconsulting.com
Ok, I think the test is attached, however you should change the name from JMMTest to something else.
like MacHostMenusTestCaseCharacterSubstitutions
On 20-Nov-08, at 1:27 PM, Stéphane Ducasse wrote:
john do you have a new version of the package since the method calculateShouldBeFrom:using: is missing
On Nov 20, 2008, at 12:03 AM, John M McIntosh wrote:
testCharacterChanging | testString item shouldBe resultingString where | #(';' '^' '!' '<' '/' '(' ) do: [:c | #('*' '* ' '* ' '**' '** ' '** ' ')' '*)' '* )' '* )' '**)' '** )' '** )' ')' '*)' '*X)' '*XX)' '**)' '**X)' '**XX)' '))' '*))' '*X))' '*XX))' '**))' '**X))' '**XX))' '(' '*(' '*X(' '*XX(' '**)' '**X(' '**XX(' '((' '*((' '*X((' '*XX((' '**((' '**X((' '**XX((' ) do: [:template | testString := template copyReplaceAll: '*' with: c. testString permutationsDo: [:mixedUp | item := mixedUp copy. shouldBe := self calculateShouldBeFrom: item using: c. resultingString := self modifySqueakMenu: item copy. self should: [shouldBe = resultingString]. (where := resultingString indexOf: $/) > 0 ifTrue: [self should: [(mixedUp at: where) = $(]. self should: [(mixedUp at: where+2) = $)]. self should: [(mixedUp at: where+1) asUppercase = (resultingString at: where+1)]]]]]
-- = = = = = = = ==================================================================== John M. McIntosh <johnmci@smalltalkconsulting.com> Corporate Smalltalk Consulting Ltd. http://www.smalltalkconsulting.com = = = = = = = ====================================================================
<JMMTest.st>
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
participants (2)
-
Marcus Denker -
Stéphane Ducasse