Re: [Pharo-dev] Bad naming: users
Iâve taken a better look at what users is doing. would classesUsing be a more specific name for that? Stephan
How about userClasses? Doru On Wed, Jan 22, 2014 at 10:38 AM, Stephan Eggermont <stephan@stack.nl>wrote:
Iâve taken a better look at what users is doing. would classesUsing be a more specific name for that?
Stephan
-- www.tudorgirba.com "Every thing has its own flow"
On 22 janv. 2014, at 10:38, Stephan Eggermont <stephan@stack.nl> wrote:
Iâve taken a better look at what users is doing. would classesUsing be a more specific name for that?
It's a bit misleading since the users of a trait are either classes or traits. Anyway, the problem is conflation of APIs, so renaming will solve your problem, but none of the ones that will eventually appear because the Class API will change. So we need mirrors or something similar.
Stephan
On 22 Jan 2014, at 16:10, Camille Teruel <camille.teruel@gmail.com> wrote:
On 22 janv. 2014, at 10:38, Stephan Eggermont <stephan@stack.nl> wrote:
Iâve taken a better look at what users is doing. would classesUsing be a more specific name for that?
It's a bit misleading since the users of a trait are either classes or traits. Anyway, the problem is conflation of APIs, so renaming will solve your problem, but none of the ones that will eventually appear because the Class API will change. So we need mirrors or something similar.
Perspectives on objects⦠;-) Marcus
participants (5)
-
Camille Teruel -
Esteban A. Maringolo -
Marcus Denker -
Stephan Eggermont -
Tudor Girba