[Review]: Issue 15567 - TxText Cleanup for Pharo 5.0 #4
I have a lot more work to do on Tx and I'd like to do it before we start using it in earnest, so if we could keep quickly reviewing and integrating these issues in particular, it would be very helpful. Thanks :) https://pharo.fogbugz.com/default.asp?15567 Fix in inbox: SLICE-Issue-15567-TxText-Cleanup-for-Pharo-50-4-SeanDeNigris.2 ### This version: - Update tests which were failing due to #selection -> #newSelection switch ### v. 1 #### Critics Browser - another pass, fix a bunch of rule violations #### TxModel - Move factory methods into a suitable protocol - Rename #cursor to #newCursor to be clear that it's not *the* cursor, but *a* cursor - Simplify selecting protocol - Only keep #newSelection, which captures the concept the best because this is a different concept than what we think of as "select all" i.e. an editor has only-one selection; here we can have any number of selections which live independently of the text - Remove other methods, which all did the same thing as the above - Remove unsent private methods #### Other - [ENH]: Clarify TxTextCursor comment ----- Cheers, Sean -- View this message in context: http://forum.world.st/Review-Issue-15567-TxText-Cleanup-for-Pharo-5-0-4-tp48... Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
2015-05-21 14:55 GMT+02:00 Sean P. DeNigris <sean@clipperadams.com>:
I have a lot more work to do on Tx and I'd like to do it before we start using it in earnest, so if we could keep quickly reviewing and integrating these issues in particular, it would be very helpful. Thanks :)
But TxText has its own repository
Fix in inbox: SLICE-Issue-15567-TxText-Cleanup-for-Pharo-50-4-SeanDeNigris.2
### This version: - Update tests which were failing due to #selection -> #newSelection switch
### v. 1 #### Critics Browser - another pass, fix a bunch of rule violations #### TxModel - Move factory methods into a suitable protocol - Rename #cursor to #newCursor to be clear that it's not *the* cursor, but *a* cursor - Simplify selecting protocol - Only keep #newSelection, which captures the concept the best because this is a different concept than what we think of as "select all" i.e. an editor has only-one selection; here we can have any number of selections which live independently of the text - Remove other methods, which all did the same thing as the above - Remove unsent private methods
#### Other - [ENH]: Clarify TxTextCursor comment
----- Cheers, Sean -- View this message in context: http://forum.world.st/Review-Issue-15567-TxText-Cleanup-for-Pharo-5-0-4-tp48... Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
Nicolai Hess wrote
But TxText has its own repository
Drats I forgot! Okay I'll copy the packages over and make a new config version. Thanks for the reminder :) ----- Cheers, Sean -- View this message in context: http://forum.world.st/Review-Issue-15567-TxText-Cleanup-for-Pharo-5-0-4-tp48... Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
Nicolai Hess wrote
But TxText has its own repository
Okay, new config version 2.10, validated by the monkey. ----- Cheers, Sean -- View this message in context: http://forum.world.st/Review-Issue-15567-TxText-Cleanup-for-Pharo-5-0-4-tp48... Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
2015-05-21 16:03 GMT+02:00 Sean P. DeNigris <sean@clipperadams.com>:
Nicolai Hess wrote
But TxText has its own repository
Okay, new config version 2.10, validated by the monkey.
There is still one change in a class that does not belong to this package: OCAbstractMethodScope all other changes are looking good, and tests are still green :)
----- Cheers, Sean -- View this message in context: http://forum.world.st/Review-Issue-15567-TxText-Cleanup-for-Pharo-5-0-4-tp48... Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
Nicolai Hess wrote
There is still one change in a class that does not belong to this package: OCAbstractMethodScope
But that method is in the "*TxText-Styler" protocol! ----- Cheers, Sean -- View this message in context: http://forum.world.st/Review-Issue-15567-TxText-Cleanup-for-Pharo-5-0-4-tp48... Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
Am 21.05.2015 5:29 nachm. schrieb "Sean P. DeNigris" <sean@clipperadams.com
:
Nicolai Hess wrote
There is still one change in a class that does not belong to this package: OCAbstractMethodScope
But that method is in the "*TxText-Styler" protocol!
Ah, sorry, didnt saw that.
----- Cheers, Sean -- View this message in context:
http://forum.world.st/Review-Issue-15567-TxText-Cleanup-for-Pharo-5-0-4-tp48...
Sent from the Pharo Smalltalk Developers mailing list archive at Nabble.com.
participants (2)
-
Nicolai Hess -
Sean P. DeNigris