[Pharo-project] About Uppercase for class instance variable
Hi I would like to know if you encountered class instance variable with starting uppercase letter? I hate that practice. Stef
(Object allSubclasses select: [:cls| cls isMeta]) select: [:cls| cls instVarNames anySatisfy: [:n | n first isUppercase] In a Core-10156 it gives me: a Set(Latin1 class EncodedCharSet class) If I open a browser I have: EncodedCharSet class instanceVariableNames: 'CompoundTextSequence' Latin1 class instanceVariableNames: 'RightHalfSequence' Shall I create an issue and rename CompoundTextSequence into compoundTextSequence and RightHalfSequence into rightHalfSequence ? Alexandre On 20 Nov 2008, at 05:49, Stéphane Ducasse wrote:
Hi
I would like to know if you encountered class instance variable with starting uppercase letter? I hate that practice.
Stef
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;: Alexandre Bergel http://www.bergel.eu ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
thanks alex. Stef On Nov 20, 2008, at 2:02 PM, Alexandre Bergel wrote:
(Object allSubclasses select: [:cls| cls isMeta]) select: [:cls| cls instVarNames anySatisfy: [:n | n first isUppercase] In a Core-10156 it gives me: a Set(Latin1 class EncodedCharSet class)
If I open a browser I have: EncodedCharSet class instanceVariableNames: 'CompoundTextSequence'
Latin1 class instanceVariableNames: 'RightHalfSequence'
Shall I create an issue and rename CompoundTextSequence into compoundTextSequence and RightHalfSequence into rightHalfSequence ?
Alexandre
On 20 Nov 2008, at 05:49, Stéphane Ducasse wrote:
Hi
I would like to know if you encountered class instance variable with starting uppercase letter? I hate that practice.
Stef
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;: Alexandre Bergel http://www.bergel.eu ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
Shall I create an issue and rename CompoundTextSequence into compoundTextSequence and RightHalfSequence into rightHalfSequence ?
So I create an issue Alexandre
On 20 Nov 2008, at 05:49, Stéphane Ducasse wrote:
Hi
I would like to know if you encountered class instance variable with starting uppercase letter? I hate that practice.
Stef
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;: Alexandre Bergel http://www.bergel.eu ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;: Alexandre Bergel http://www.bergel.eu ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
ISSUE #342 (Object allSubclasses select: [:cls| cls isMeta]) select: [:cls| cls instVarNames anySatisfy: [:n | n first isUppercase] In a Core-10156 it gives me: a Set(Latin1 class EncodedCharSet class) If I open a browser I have: EncodedCharSet class instanceVariableNames: 'CompoundTextSequence' Latin1 class instanceVariableNames: 'RightHalfSequence' CompoundTextSequence is renamed into compoundTextSequence RightHalfSequence is renamed into rightHalfSequence This fix makes this instance variable perserve their values. SLICE-RenamingInstanceVariable-Alexandre_Bergel.2 in PharoInbox Alexandre On 20 Nov 2008, at 10:26, Stéphane Ducasse wrote:
thanks alex.
Stef
On Nov 20, 2008, at 2:02 PM, Alexandre Bergel wrote:
(Object allSubclasses select: [:cls| cls isMeta]) select: [:cls| cls instVarNames anySatisfy: [:n | n first isUppercase] In a Core-10156 it gives me: a Set(Latin1 class EncodedCharSet class)
If I open a browser I have: EncodedCharSet class instanceVariableNames: 'CompoundTextSequence'
Latin1 class instanceVariableNames: 'RightHalfSequence'
Shall I create an issue and rename CompoundTextSequence into compoundTextSequence and RightHalfSequence into rightHalfSequence ?
Alexandre
On 20 Nov 2008, at 05:49, Stéphane Ducasse wrote:
Hi
I would like to know if you encountered class instance variable with starting uppercase letter? I hate that practice.
Stef
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;: Alexandre Bergel http://www.bergel.eu ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
-- _,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;: Alexandre Bergel http://www.bergel.eu ^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;._,.;:~^~:;.
participants (2)
-
Alexandre Bergel -
Stéphane Ducasse