[Pharo-project] What is the difference between ActionSequence and WeakActionSequence
In 1.3 they look the same, in 1.4 ActionSequence is not there any more... Is the second one replacing the first one? are there any differences for the user? Thanks, Guille
On Jan 13, 2012, at 4:33 23PM, Guillermo Polito wrote:
In 1.3 they look the same, in 1.4 ActionSequence is not there any more...
Is the second one replacing the first one? are there any differences for the user?
Thanks, Guille
ActionSequence was not referenced by the base system any more, not sure why it was removed instead of deprecated. And yes, there is a difference for a user, the WeakActionSequence holds actions weakly, while ActionSequence held them strongly. (WeakActionSequence automatically removes the actions when there are no other references to the registrar, while ActionSequence did not, and you had to unregister manually before it would stop executing them) Cheers, Henry
But they are both defined the same way! Array variableSubclass: #WeakActionSequence instanceVariableNames: '' classVariableNames: '' poolDictionaries: '' category: 'Kernel-Objects' The only reference to it's weakness it its name! :P On Fri, Jan 13, 2012 at 12:39 PM, Henrik Johansen < henrik.s.johansen@veloxit.no> wrote:
On Jan 13, 2012, at 4:33 23PM, Guillermo Polito wrote:
In 1.3 they look the same, in 1.4 ActionSequence is not there any more...
Is the second one replacing the first one? are there any differences for the user?
Thanks, Guille
ActionSequence was not referenced by the base system any more, not sure why it was removed instead of deprecated. And yes, there is a difference for a user, the WeakActionSequence holds actions weakly, while ActionSequence held them strongly. (WeakActionSequence automatically removes the actions when there are no other references to the registrar, while ActionSequence did not, and you had to unregister manually before it would stop executing them)
Cheers, Henry
On Fri, Jan 13, 2012 at 4:44 PM, Guillermo Polito <guillermopolito@gmail.com
wrote:
But they are both defined the same way!
Array variableSubclass: #WeakActionSequence instanceVariableNames: '' classVariableNames: '' poolDictionaries: '' category: 'Kernel-Objects'
The only reference to it's weakness it its name! :P
I also see
asActionSequenceTrappingErrors
^WeakActionSequenceTrappingErrors withAll: self ;)
On Fri, Jan 13, 2012 at 12:39 PM, Henrik Johansen < henrik.s.johansen@veloxit.no> wrote:
On Jan 13, 2012, at 4:33 23PM, Guillermo Polito wrote:
In 1.3 they look the same, in 1.4 ActionSequence is not there any more...
Is the second one replacing the first one? are there any differences for the user?
Thanks, Guille
ActionSequence was not referenced by the base system any more, not sure why it was removed instead of deprecated. And yes, there is a difference for a user, the WeakActionSequence holds actions weakly, while ActionSequence held them strongly. (WeakActionSequence automatically removes the actions when there are no other references to the registrar, while ActionSequence did not, and you had to unregister manually before it would stop executing them)
Cheers, Henry
-- Mariano http://marianopeck.wordpress.com
On Fri, Jan 13, 2012 at 4:48 PM, Mariano Martinez Peck < marianopeck@gmail.com> wrote:
On Fri, Jan 13, 2012 at 4:44 PM, Guillermo Polito < guillermopolito@gmail.com> wrote:
But they are both defined the same way!
Array variableSubclass: #WeakActionSequence instanceVariableNames: '' classVariableNames: '' poolDictionaries: '' category: 'Kernel-Objects'
The only reference to it's weakness it its name! :P
I also see
asActionSequenceTrappingErrors
^WeakActionSequenceTrappingErrors withAll: self
;)
But ActionSequence is the same jahahahha
On Fri, Jan 13, 2012 at 12:39 PM, Henrik Johansen < henrik.s.johansen@veloxit.no> wrote:
On Jan 13, 2012, at 4:33 23PM, Guillermo Polito wrote:
In 1.3 they look the same, in 1.4 ActionSequence is not there any more...
Is the second one replacing the first one? are there any differences for the user?
Thanks, Guille
ActionSequence was not referenced by the base system any more, not sure why it was removed instead of deprecated. And yes, there is a difference for a user, the WeakActionSequence holds actions weakly, while ActionSequence held them strongly. (WeakActionSequence automatically removes the actions when there are no other references to the registrar, while ActionSequence did not, and you had to unregister manually before it would stop executing them)
Cheers, Henry
-- Mariano http://marianopeck.wordpress.com
-- Mariano http://marianopeck.wordpress.com
What is that? ActionSequence? Who use that?
But they are both defined the same way!
Array variableSubclass: #WeakActionSequence instanceVariableNames: '' classVariableNames: '' poolDictionaries: '' category: 'Kernel-Objects'
The only reference to it's weakness it its name! :P
On Fri, Jan 13, 2012 at 12:39 PM, Henrik Johansen <henrik.s.johansen@veloxit.no> wrote:
On Jan 13, 2012, at 4:33 23PM, Guillermo Polito wrote:
In 1.3 they look the same, in 1.4 ActionSequence is not there any more...
Is the second one replacing the first one? are there any differences for the user?
Thanks, Guille
ActionSequence was not referenced by the base system any more, not sure why it was removed instead of deprecated. And yes, there is a difference for a user, the WeakActionSequence holds actions weakly, while ActionSequence held them strongly. (WeakActionSequence automatically removes the actions when there are no other references to the registrar, while ActionSequence did not, and you had to unregister manually before it would stop executing them)
Cheers, Henry
On Fri, Jan 13, 2012 at 5:32 PM, Stéphane Ducasse <stephane.ducasse@inria.fr
wrote:
What is that? ActionSequence? Who use that?
So far, OB :P
But they are both defined the same way!
Array variableSubclass: #WeakActionSequence instanceVariableNames: '' classVariableNames: '' poolDictionaries: '' category: 'Kernel-Objects'
The only reference to it's weakness it its name! :P
On Fri, Jan 13, 2012 at 12:39 PM, Henrik Johansen < henrik.s.johansen@veloxit.no> wrote:
On Jan 13, 2012, at 4:33 23PM, Guillermo Polito wrote:
In 1.3 they look the same, in 1.4 ActionSequence is not there any more...
Is the second one replacing the first one? are there any differences for the user?
Thanks, Guille
ActionSequence was not referenced by the base system any more, not sure why it was removed instead of deprecated. And yes, there is a difference for a user, the WeakActionSequence holds actions weakly, while ActionSequence held them strongly. (WeakActionSequence automatically removes the actions when there are no other references to the registrar, while ActionSequence did not, and you had to unregister manually before it would stop executing them)
Cheers, Henry
Ah yeas now I remember this is event raising when:to:do:⦠Yet another thing unused but not totally and probably a bit shaky. Some points for the future: - I do not understand why this is not packaged with EventManager - We want to remove DependentFields from Object like in CUIS and we will probably use, fix and reduce the API of actionSequence. just 27 methods in Object. - Now this is strange that ActionSequence got removed. - I do not understand why this is called ActionSequence, the name does not tell much. May be this is the equivalent of DependencyTransformer in VW. It looks also quite similar to announcement. So once we have ephemerons may be we should move to announcement this behavior - The related question is do we want any object to be able to register to event. I have serious doubt about that and we could: - have a trait - define a subclass of Object
participants (4)
-
Guillermo Polito -
Henrik Johansen -
Mariano Martinez Peck -
Stéphane Ducasse