Re: [Pharo-project] Replacing 'ReadStream on smth:' by 'smth readStream'
Adrian, Damien, I suspect that Damien's goal is to simplify replacing ReadStream. If we can do that by ReadStream := SomethingElse. then #on: might be fine as it is. I do suspect that the RB is the best and most practical way to cope with #next. Bill Wilhelm K. Schwab, Ph.D. University of Florida Department of Anesthesiology PO Box 100254 Gainesville, FL 32610-0254 Email: bschwab@anest.ufl.edu Tel: (352) 846-1285 FAX: (352) 392-7029
adi@netstyle.ch 05/30/08 8:18 AM >>> Have you verified that your change does not inadvertently modify any behavior? Its not likely, but changes like this can introduce subtle bugs. For instance, Matrix overrides readStream. So if there exists any use of "ReadStream on: aMatrix" that is there to bypass the overridden behavior, the code will break.
Cheers, Adrian On May 30, 2008, at 10:47 , Damien Cassou wrote:
Hi,
I've just published in the pharo inbox a package for the System category. This change has been generated automatically through the rewriter:
ParseTreeRewriter new replace: 'ReadStream on: ``@object' with: '``@object readStream'; yourself
The formatting of the changed method is completely different due to the use of the refactoring browser. This makes the diffs not readable. Even if it is a real problem, I don't see any simple solution. What do you think?
-- Damien Cassou Peter von der Ahé: «I'm beginning to see why Gilad wished us good luck». (http://blogs.sun.com/ahe/entry/override_snafu)
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
_______________________________________________ Pharo-project mailing list Pharo-project@lists.gforge.inria.fr http://lists.gforge.inria.fr/cgi-bin/mailman/listinfo/pharo-project
participants (1)
-
Bill Schwab