Bad naming of libfreetype in latest Pharo vm windows 64bits
Hi all, I'm trying the latest windows pharo VM 64bits (pharo-win-x86_64-201901051900-7a3c6b6.zip from http://files.pharo.org/vm/pharo-spur64/win/) to see how reproducible are the problems with freetype, athens and the bitblt. While in that I've found that libcairo does not load due to a bad naming of libfreetype. I had libfreetype.dll, and renaming it to libfreetype-6.dll made it loadable again. The 32bit windows VM that corresponds to the same commit, the freetype library file is also named libfreetype.dll but there it works. I've found that the specs for freetype for win64 in that commit are right: https://github.com/OpenSmalltalk/opensmalltalk-vm/blob/7a3c6b642312bc2778fd8... but maybe the default ones are used? https://github.com/OpenSmalltalk/opensmalltalk-vm/blob/7a3c6b642312bc2778fd8... Does somebody know what else could be causing this? Tx, Guille
participants (1)
-
Guillermo Polito