On Apr 17, 2014, at 10:08 AM, Yuriy Tymchuk <yuriy.tymchuk@me.com> wrote:

I would rather rename is to Block, as everyone is calling it a �block�.

That might be actually a good idea

sebastian

o/

PS: thinking in that line there is also �Context� as, conceptually, what these blocks of code want to do is to keep the evaluation in a specific context. But to ease know-how transference and type less I�d rather go with the most popular name, as you suggested: �Block'