On 27 Jul 2015, at 7:42 , stepharo <stepharo@free.fr> wrote:

Probably that the gain is not enough.
This is just annoying to not have surrounding.

Le 27/7/15 18:20, Peter Uhn��k a ��crit :
 
is performance so critical that using $( rather than '('
gains a lo
There's visual gain that I've mentioned. If you replace $( with '(' then my argument about visibility fails. $( is very distinct.
 
Maybe it is also a useful pattern for markup languages:

    aStream between: '<HEAD>' and: '</HEAD>' putAll: [
          ... nextLevelIn ... ].

I don't think it's a good practice to generate individual tags by hand, you should have more abstraction.

Pillar has

PRHTMLTag>>with: aString
stream << $> << aString << '</' << name << $>

Apart from it being hard to read due to </> it's so simple that it doesn't matter and you have little to no gain in trying to make it "nicer".

Peter



Faced with a choice of using multiple nextPut: / nextPutAll:'s, and using a selector like surround:with:and:, or was that put:and:around:, or did it included between: somehow?
I think I know which I'd end up writing every single time.

Same reason I think a lot of the specialized collect:/select:'s out there is pure bloat in a base image, and better left defined to users who prefer it.

Cheers,
Henry