Sounds like a good idea, but please implement them as constructors/class side methods in Halt instead of adding even more methods to Object.


"self haltIfTest -> Halt ifTest"


Best regards,

Henrik


Fra: Pharo-dev <pharo-dev-bounces@lists.pharo.org> p� vegne av Denis Kudriashov <dionisiydk@gmail.com>
Sendt: 3. juni 2017 21:30:37
Til: Pharo Development List
Emne: Re: [Pharo-dev] New and richer halt messages
 

2017-06-03 15:21 GMT+02:00 Sean P. DeNigris <sean@clipperadams.com>:
To mirror the existing API, what do you think of:
  - haltOnlyInTest -> #haltIfTest
  - haltOnlyOutOfTest -> #haltIfNotTest
  - haltOnlyMe -> #haltOnly

good names. We need right english overview :)