Hello.
I found very interesting method.

Should it really be like that? 
Or maybe we need to rename this method as #roundedCenter and add the normal #center with usual division? 
Best regards,
Natalia