2014-11-05 12:29 GMT+01:00 Ben Coman
<btc@openinworld.com>:
Sean P. DeNigris wrote:
Ben Coman wrote
I think this shows its fairly well established that 'Browse' on its own means "view the object's code"
I still vote to change it to more clearly reveal the intention. While
perhaps not particularly significant in itself, all these little "gotchas"
pile up for newbies, and rob mental energy from everyone's creative
expression. Alan Kay ballparked Squeak at "Encyclopedia Brittanica" LOC,
down from Windows' "Empire State Building" LOC, but IMHO mastering an entire
Encyclopedia is hard enough without a lot of special cases.
-----
Cheers,
Sean
I thought more on this during the day and came to the conclusion that the least surprising would be...
Object>>#browseClass
^ self systemNavigation browseClass: self class
Object>>#browse
self browseClass
I find
Object>>#browse
self class browse
perfectly clear as well. And removes one unneeded selector on Object.