On 22 Feb 2014, at 18:49, Tudor Girba <tudor@tudorgirba.com> wrote:

Excellent, Stef!

I reviewed a bit the code:
- The name log denotes the recording of multiple events. However, the Log class models only one event, not many. Thus, a more suitable name would be LogEvent. Or maybe LogEntry (like in StarTrek :))

in the class comment :)

!! Design notes.
I'm named Log and not SLLogObject or whatever because I'm the main entry point for a client point of view. 

- Similarly, SystemLogger>>logs should be something like logEvents/logEvents.

I changed it to logEntries. 

I�m interested in extensions to stress the design and extension points of SystemLogger :)
On 22 Feb 2014, at 18:49, Tudor Girba <tudor@tudorgirba.com> wrote: