I vote for renaming to��Rectangle>>translatedBy:, because it returns a new translated rectangle instance.

-1
There is no benefit in renaming a single method, apart from creating more confusion.
If anything, the whole Rectangle API would have to be changed, as there is plethora of similar methods (expandBy:, extendBy:, merge:, etc.)

Pretty much all Rectangle messages are immutable and create new Rectangle, thus I feel it is unnecessary to state it explicitly.

In VW there is plenty of methods (e.g. left:) that mutates it, thus unlike Pharo a clear distinction is required.

Peter