Hello.
What about logging levels?
I like "logInfo:", "logDebug:", "logTrace:". Or maybe it is better to split log with levels: "self log info:", "self log debug:", "self log trace:"
Best regards,
Denis2013/5/5 St�phane Ducasse <stephane.ducasse@inria.fr>Hi guys
Stupidly I introduced log: a while ago to replace Transcript show:. Now is the current situation.
I still want to remove all the use of Transcript show:
Now since I thought I did a mistake with log: because it overload Integer>>log: I introduced trace: and traceCr:
Now I do not like traceCr: because it is not a cool message.
So what do we do:
1) we use crLog:, logCr:
and deprecated log:
2) we use crTrace:, trace: and traceCr:
I really prefer solution 1 but I would like to hear from you.
Stef