P.S. regardless.. about the subject, so, now

Here's an example

nil asValueHolder

shall be refactored to

nil asReactiveVariable

?

sounds like a plan :)
====

And yes, Ben, you are wrong, if you consider this as a personal attack.
This code smells, to say it politely. But i prefer to call it crap.
When i see such things, the only thing, which comes to my mind is: 'when the only tool you have is a hammer, you tend to treat everything as nail'.

But this is example to show you that when your college says "you're wrong" it don't actually means "i hate you and you should leave".
You should probably learn to make a difference between "fundamentalist's hatred" towards bad code/design decisions, and "hatred based on personal basis".

Because i do, and while i hate bad code, and can explode with curses & blasphemy, it doesn't means that i am targeting its author. No, it is just the code.
I am really miss your company and your sense of humor. To my opinion, you was a part of what was making a great atmosphere in our team, at least for me.

Too bad, that you decided to leave, instead of standing and fighting, defending your opinion and proving it right. Because this is what i would do, considering the amount�� of energy i put into it, and based on honest and strong will to make it even better.

--
Best regards,
Igor Stasenko.