Additionally it was annoying if a superclass has a method with the same name. For example if you have a name var and you create accessors I���d like to have actually a ���name��� getter and not ���name1���