2009/10/29 Adrian Kuhn <akuhn@iam.unibe.ch>
Dennis Schetinin <chaetal@...> writes:

> �� � � �stack := self given: #shouldBeEmpty.
> I'd suggest this to be:�
>
> �� � �� stack := self given: [self shouldBeEmpty].
> This way it's easier to follow what happenning, and refactoring can be applied.

Refactoring should not be a problem, it treats symbols the same way as message
sends. For example, when you rename a method, nut just senders but also all
symbols are renamed.

That's right, my mistake. Anyway IMHO using explicit message sends is preferable, no?

--
Dennis Schetinin