On 19 Aug 2016, at 04:13, Martin Dias <tinchodias@gmail.com> wrote:Hi Stef, I come back to your observation about the words Redo and Undo used in Epicea menu. You proposed to use Import and Revert instead.
Originally I chose redo/undo because they are very well known terms in text editing UIs, but it is true that they are different: in regular UIs you can't select an arbitrary operation in the history and redo or undo it, like in Epicea. So other names can be more adequate...
any other opinion?
Martin
ps: other alternative is apply+"apply inverse"
ps2: I'm preparing a major update in Epicea's UIs, which already has some renames.
<PharoScreenshot.1.png>
���
El 7/8/2016 3:16, "stepharo" <stepharo@free.fr> escribi��:
Le 5/8/16 �� 05:28, Martin Dias a ��crit :
Thanks MartinHi Stef, good, I take note. I improved filters in the recent releases and will continue improving.
I have problems with the menu item names :)
To me redo looks strange
when I get a crash I want to import the changes not redo them.
Then I do not get what undo means (yes I know this is probably revert)
May be some pharoers have better names than mine.
Stef
Martin
On Wed, Aug 3, 2016 at 5:30 PM, stepharo <stepharo@free.fr> wrote:
Thanks Martin.
We missed yesterday: show only the latest version of every entities. :)
Setf
Le 3/8/16 �� 11:23, Marcus Denker a ��crit :
On 03 Aug 2016, at 11:07, GitHub <noreply@github.com> wrote:ChangeLog for this:
Log Message:
-----------
60163
18831 Integrate new Epicea version
https://pharo.fogbugz.com/f/cases/18831
- Case 18813: Implement redo and undo of protocol addition and removal.
- Case 18612: disable drag&drop until TreeModel supports it correctly.
- Case 18384: Redo and undo: show on any selection (not only when all selected entries are code changes).
- Enhancement: Improve lost changes detection; show only the events actually lost.
- Enhancement: Pass on filters.
- Clean up: Do not show the "absent entry" item anymore since it was not useful at all.
- Clean up: Remove unused "commit tags" in log browser.
- Clean up: Remove unused tests. They were good idea, we can re-introduce them but working and covering more cases.
- Clean up: Rename #displayWidget to #asMorph in EpLogBrowserItem''s hierarchy. It is more meaningful.
- Workaround: Hide "Open in Sorter" menu action since it is useless until Treemodel drag&drop is fixed.
18768 Inlined method const could be implemented by metalinks
https://pharo.fogbugz.com/f/cases/18768
18835 Update RBParser-Nodes class comments
https://pharo.fogbugz.com/f/cases/18835
http://files.pharo.org/image/60/60163.zip