This one looks strange and seems indeed to be dead code.��
Maybe it was an attempt to make a specific class definition keyword for CompiledMethod / CompiledCode / CompiledBlock. Right now there is a specific case in the code somewhere to use the specific compiledCode layout for those 3 classes instead of the byte layout which is normally used for the keyword��variableByteSubclass: that those 3 classes use.
I am not sure��immediateByteSubclass: makes sense though. I would rather have compiledCodeSubclass, variablePointerAndByteSubclass or something like that.