Hi

I wrote proposal in issue

2017-08-18 0:52 GMT+02:00 Tim Mackinnon <tim@testit.works>:
Is this a goal we can all share for 7.0?

Sort out the expert tools (like git etc), but equally enable that simplicity you expect for a child/newbie/expert...

I'm in!

Tim

Sent from my iPhone

> On 17 Aug 2017, at 20:52, Stephane Ducasse <stepharo.self@gmail.com> wrote:
>
> Hi guys
>
> my son coded in Pharo 60
>
> testGuessUrlPart
>
>�� �� �� |dg8|
>�� �� �� dg8 := GameItem new;
>�� �� �� �� �� �� �� �� �� name: 'Dragon Quest VIII : Journey Of The Cursed King';
>�� �� �� �� �� �� �� �� �� console: 'PS2'.
>�� �� �� ��self assert: dg8 guessUrlPart equals:
> 'dragonquestviiijourneyofthecursedking'
>
> and guess what he broke the system.
>
> We should not accept such kind of behavior.
> name: should not change the name of the class.
>
> I do not know the solution but I fear when I will teach 160 students this fall.
> We should make sure that Pharo is not a system only for experts!
>
> any idea is welcome
>
> https://pharo.fogbugz.com/f/cases/20322/name-sent-to-a-class-SHOULD-NOT-automatically-rename-and-destroy-the-class
>
> Stef
>