On 26 Jul 2015, at 10:55, stepharo <stepharo@free.fr> wrote:


I prefer
   ban this rule = do not run it
   false positive = rule is ok but wrong here

Do you mean ban rule completely? On which level? For a developer (machine)?

in the codecritcis the scope is clear.
On a class or a package.

How is it different from false positive on a method or a class. Please do not misunderstand me, but this is a part of story telling. If you don���t want to see a critic (of a class or a method), you mark it as false positive. Now you can also ban rule on the level of a class or package, so you will not see the critics about it. For me this two stories are intersecting. Why not simply say: ���If you don���t want to see this critic anymore (for any reason), then you can ban it on the level of method, class, tag, package, or whole system���. This way the story is simpler.


Then again, skip works as former ���false positive���. But in my opinion ���false positive��� is not a good name from the logical point of view. You have a rule that detects if you have no #yourself message in the end of a cascade. Now do people really mark this as ���false positive��� if the rule detects cascades that have #yourself message in the end? Or they do it if they don���t want to see the critic? Then it���s not false positive, then they just want to hide or ���skip��� the rule.
Sorry but I do not understand your argument.
For me this is simple:
    the rule tells me something is wrong and it is not.
    -> so I mark it as false positive.

This is fun part from statistics to name things as false positives. But if we program a rule in such way, that it is fuzzy, I think that it���s not correct to call it as false positive. Maybe it���s critics are useless more times that they are helpful, and if the critic is correct, the issue is not that important. Then probably we should just remove the rule or rewrite it.

Now with useless button, the only reason is to collect data on which rules are actually useless to people [1], so we can take a look at them in a first place. It doest not affect the functionality.

I do not like useless. Because it is too violent and unclear.
Please again have a look at the vocabulary used in the CodeCritics and the chapter that describes it.
Or you should fix everything but we should not have two different vocabularies.
There is enough confusing terms in Pharo so that we do not add more.

I understand. I will re-read the vocabulary and fix discrepancies. But please read my argument bout duplicated behavior of banking and marking as false positive, I think that it may be confusing.

Also ���Useless" button does not do anything besides sending me an information that this critic was useless to somebody. Ideally there should be no button like this and I should be able to collect user actions that they perform. But from server/privacy/time perspective it was easier for me to make a simple button. Would be nice to have an advanced data collection, but I am not sure that I will have time now to program all that, so if it is bothering so much, I can simply remove it.

Uko


Stef





Stef


Uko

On 23 Jul 2015, at 22:29, stepharo <stepharo@free.fr> wrote:

HI yuriy

it would be good that quality assistant uses the same vocabulary than codecritics.
for example
   skip -> ban?
   marks as false positif?

Stef