���ifNone: is a nice idiom, but not always available (in which case, we should think about introducing it)

?? is basically an infix but eager version of #ifNil:, IMHO a pragmatic thing to have; could be quite handy.
My only fear is that it could encourage the use of nil instead of proper Null Objects��� and here we start bikeshedding

On 20 May 2015 at 21:31, Sergio Fedi <sergio.fedi@gmail.com> wrote:

In my experience those situations end up been handled by collections, detect:ifNone: which even handles the case when all defaults are nil.

But maybe that idiom is very common in another situations.



--
Damien Pollet
type less, do more [ | ] http://people.untyped.org/damien.pollet