Would it be possible to instead have a #haltIf object to which you can send additional conditions?E.g.self haltIf insideTestself haltIf outsideTestMakes it (imho) a bit more readable, adds just a single method to Object, and allows for more potential extensions...self haltIf nil.self haltIf count: 3.etc?PeterOn Wed, Apr 4, 2018 at 8:36 AM, Christophe Demarey <christophe.demarey@inria.fr> wrote:
> Le 4 avr. 2018 �� 04:34, Sean P. DeNigris <sean@clipperadams.com> a ��crit :
>
> demarey wrote
>> What about haltIfTestExecutionEnvironment and
>> haltIfDefaultExecutionEnvironment ? At a first look #haltInsideTest and #haltOutsideTest do not tell me that they are conditional breakpoints.
>
> I thought the names were okay. What did you think was unclear about them?
maybe just add a if would solve that: #haltIfInsideTest #haltIfOutsideTest