Can we remove #brickValue: ?
I don't see how this is different from #cull:
And the name is strange, I don't see how this depends an a brick.
Not really, it is implemented also in Object.
It is used to script brick layout properties. So user can say:
brick height: 10.
brick height: #approximate.
brick height: [ :b | b width * 2].
or even
brick height: HeightStrategy new.
so brickValue: is sent to any kind of object that is used as height. So without changing brick itself user can implement its own class and override brickValue: and have custom strategy to calculate height.
Such practice is used in many places in brick.