Ben Coman wrote
>
> But after pondering a while for a better name, I wonder what is wrong with
> the existing?
> Googling "define aggregate" provides...
>�� �� ��aggregate (noun) = a whole formed by combining several separate
> elements.
>�� �� ��aggregate (verb) = form or group into a class or cluster.
>
> The separate elements are runs defined by the block.
> The existing name seems quite precise to me.
>
> cheers -ben
When I read aggregateRuns:, I think the opposite; something combining
different runs into a single entity, not something that splits a single
collection into constituent runs...
Something like (split/collect)runsAccordingTo: sounds more descriptive to my
ears, at least.
Cheers,
Henry
--
Sent from: http://forum.world.st/Pharo-Smalltalk-Developers-f1294837. html