Yes, exactly how it felt. Maybe #setImmutable would be more intention revealing.

Phil

On Wed, Jan 25, 2017 at 11:47 AM, Norbert Hartl <norbert@hartl.name> wrote:

Am 25.01.2017 um 11:40 schrieb Denis Kudriashov <dionisiydk@gmail.com>:


2017-01-25 11:35 GMT+01:00 Norbert Hartl <norbert@hartl.name>:
ASUser new
�� �� �� �� setIsReadOnlyObject: true

And why so ugly name? Why not #isReadOnlyObject:?

To be honest I think #isReadOnlyObject: is worse :) isXXX is a prefix for testing methods. isXXX with an argument feels even more strange. I would rather have #beReadOnly��

Norbert