2016-01-09 22:51 GMT+01:00 Tudor Girba <tudor@tudorgirba.com>:
Hi,

> On Jan 9, 2016, at 10:23 PM, Nicolai Hess <nicolaihess@gmail.com> wrote:
>
>
>
> 2016-01-09 20:52 GMT+01:00 Francisco Ortiz Pe��aloza <patchinko@gmail.com>:
> Hi,
>
> i would like to have the GTDebugger in the near future. Great job and thanks!
>
> I like the Esteban built instead of the original one and i agree with stef on removing _stack and _thisContext from top and the bytecode view. Aim to simplicity must be a top priority and if anybody needs something more specific can change it easily (its moldable!)
>
> I often use thisContext and stackTop for inspecting the current context (I use this a lot when debugging compiler errors) and
> the stackTop when stepping through cascaded message send, I want to see the intermediate return value.

Indeed, I use them too, but not too often. That is why Andrei and I think maybe they should be in the menu of hte stack and have them appear in the inspector below. What do you think?

I don't know. At the moment I would say, keep it. It is a valuable information about the current state of the execution. But
if you implement it as you described, I will test and give feedback.

I would not change the name of thisContext to _thisContext. The name "thisContext" is a valid and evaluatable variable name. It is confusing if we show it as "_thisContext" just to tell it appart from
"normal" variable names. There is a "type" column, this could be used to name this kind of variable ("pseudo Var" for example).

��

Cheers,
Doru

>
>
> Cheers
> Francisco
>
>
>
> On Sat, Jan 9, 2016 at 12:07 PM, Henrik Nergaard <henrik.nergaard@uia.no> wrote:
> http://ws.stfx.eu/3KXXDAJ4EUF6
>
>
> -----Original Message-----
> From: Pharo-dev [mailto:pharo-dev-bounces@lists.pharo.org] On Behalf Of Stephan Eggermont
> Sent: Saturday, January 9, 2016 3:36 PM
> To: pharo-dev@lists.pharo.org
> Subject: Re: [Pharo-dev] gtdebugger in pharo 5.0
>
> On 09-01-16 12:39, Dimitris Chloupis wrote:
> > there has been around a script to automate the screenshots, but
> > personally I never bother using it because taking a screenshot and
> > inserting in pillar is the easiest thing.
>
> AFAIK the hard part is keeping things up to date. That's where automation helps.
>
> Stephan
>
>
>
>
>

--
www.tudorgirba.com
www.feenk.com

"Every thing has its own flow."