Hi Serge,

I vote for renaming to��Rectangle>>translatedBy:, because it returns a new translated rectangle instance.
For example in bloc there is BlUserInputEvent and it has two methods: translateBy: and translatedBy:.
First one actually modifies position (mutates object) the second one creates a translated copy of the event.
Hence Rectangle is suppose to be immutable I think translatedBy: is better name.

Cheers,
Alex

On Tue, May 26, 2015 at 2:41 PM, Serge Stinckwich <serge.stinckwich@gmail.com> wrote:
In Pharo 4.0, there is a Rectangle>>translateBy: aFactor method.
The same method in VW is called translatedBy:

In Pharo, there is also a translatedToBeWithin: and
translatedAndSquishedToBeWithin:
and scaledBy:

Just to be consistent, this is maybe better to use translatedBy:
instead of translateBy: ?

--
Serge Stinckwich
UCBN & UMI UMMISCO 209 (IRD/UPMC)
Every DSL ends up being Smalltalk
http://www.doesnotunderstand.org/