Le 21 avr. 2015 � 10:44, Sven Van Caekenberghe a �crit :


On 21 Apr 2015, at 10:36, Christophe Demarey <Christophe.Demarey@inria.fr> wrote:

To come back to my proposition, it is just a first step to BDD to not prevent people to define tests with something like shouldAccountBalanceBePositiveAfterEachOperation (more behavior driven) rather than testMyWonderfulMethod that may leads people to test the implementation details and not the expected behavior.

Not that your naming ideas are bad, but right now you can write

testAccountShouldBePositiveAfterEachOperation

which is not that bad

I agree. I do not want to push things that won't be used. That's why I did not yet proposed a slice.
Maybe I will just let it as it is now and just propose to include the refactoring to have the logic of the test selection in one place.
With Guille, we discussed a bit around tests and came to the conclusion that it would be good to have a blog post or a book chapter on test solutions and how to test the good thing.
We have, for example:

Thanks for the feedback.