Hi��

Several questions on bloc

- Would it make sense to rename BlElement into BlGraphicalElement?��

- Could we rename drawPathOnSpartCanvas: -> drawOn:? or drawPathOn:��


- What is the difference between a shapeFactory and a Geometry?��

- Does a Geometry can build path too?

I saw that the Factory is in Sparta while the Geometry in Bloc
I thought because of��buildPathOnSpartaCanvas: aCanvas within: aBounds

- Why the ShapeFactory does not delegate its logic to the Geometry object?


- Why BlGeometryElement is not called BlGeometricalElement?

- How a BlLine relates to a BlLineElement?

BlLineElement >> defaultGeometry
^ BlLine new

Would it not be better to have an instance variable like that we do not force extender to only use inheritance? With an instance variable and setter��

We could do��

BlLineElement new geometry: MyBlLine new.