I even added a lint rule detecting calls to #methodDict.
So I do not get it and personally I would not deprecate methodDictionary and I would remove
methodDict because it sucks!
methodDict should *never* be used from the outside. It�s far too easy to get problems because you modify the dictionary
without e.g. invalidating the VM cache or telling the system.
And it gets *much* easier to read:
methodDict values �> methods
methodDict keys �> selectors
methodDict size > 0 �> #hasMethods
and so on� it�s amazing how much more readable code gets.
So why do we provide a �nice� selector �methodDictionary� if this is a private accessor for internal state?
If we do that it communicates �use me�! And you should not. If you want to use it, you know what you are doing
and you know #methodDict.