2013/12/17 kilon alios <kilon.alios@gmail.com>
Tried your installation instructions on Pharo 3 latest build and I get this errorThe method AbstractFileReference>>ensureDirectory has been deprecated.Use ensureCreateDirectoryThis deprecation should be new :)Phratch works on Pharo2.0.I can load it on the latest one click of Pharo3.0 also.�this is the full stack traceMorphicUIManager>>warningDefaultAction:Deprecation(Warning)>>defaultActionDeprecation>>defaultActionUndefinedObject>>handleSignal:MethodContext(ContextPart)>>handleSignal:MethodContext(ContextPart)>>handleSignal:MethodContext(ContextPart)>>handleSignal:Deprecation(Exception)>>signalFileLocator(Object)>>deprecated:on:in:FileLocator(AbstractFileReference)>>ensureDirectoryPhratchFileChooserDialog class>>userPhratchProjectsDir in Block: [ (homeDir / phratchFolderName) ensureDirectory ]BlockClosure>>on:do:BlockClosure>>ifError:PhratchFileChooserDialog class>>userPhratchProjectsDirPhratchFileChooserDialog class>>getDefaultFolderForType:PhratchFrameMorph>>newPhratchProjectPhratchFrameMorph>>startupPhratchFrameMorph class>>openUndefinedObject>>DoItOpalCompiler>>evaluateSmalltalkEditor>>evaluateSelectionAndDo:SmalltalkEditor>>evaluateSelectionPluggableTextMorph>>doIt in Block: [ textMorph editor evaluateSelection ]PluggableTextMorph>>handleEdit: in Block: [ result := editBlock value ]TextMorphForEditView(TextMorph)>>handleEdit:PluggableTextMorph>>handleEdit:PluggableTextMorph>>doItWorkspace(Object)>>perform:orSendTo:ToggleMenuItemMorph(MenuItemMorph)>>invokeWithEvent: in Block: [ ...BlockClosure>>ensure:I cannot open Phratch because of this error. Each time I follow the instructionsPhratchFrameMorph open.I get the same error.I am on win7 64bit.�Also a note , personal opinion, I dont like the name. To be sincere I never liked "Scratch" as a name either. It sounded to me like an allergy. But "Phratch" as a name makes even less sense.�Ok, I understand your point. Now I have no better name. Any idea ?But should we change the name ?That are open questions.Cheers,Jannik�On Tue, Dec 17, 2013 at 4:02 PM, Hilaire Fernandes <hilaire.fernandes@gmail.com> wrote:
Le 16/12/2013 22:45, jannik.laval a �crit :
> I continue to develop Phratch, the port of Scratch in Pharo.It is fantastic you ported and keep improving this Smalltlak Jewel on
> Phratch is a visual programming language on top of Pharo.
>
Pharo ;).
Thanks
Hilaire
--
Dr. Geo http://drgeo.eu
--~~Jannik�Laval~~
�cole des Mines de Douai
Enseignant-chercheur
http://www.jannik-laval.eu
http://car.mines-douai.fr/