On 5 Apr 2018, at 09:10, Marcus Denker <marcus.denker@inria.fr> wrote:On 3 Apr 2018, at 21:56, Christophe Demarey <christophe.demarey@inria.fr> wrote:Nice addition!I should say that names are not really intention revealing.What about haltIfTestExecutionEnvironment and haltIfDefaultExecutionEnvironment ?To long and too implementation centered.I would even shorten it to haltIfTest and haltIfNotTest.