I read class comments and seem to be different, but I don't like the name at all. We should rename (or remove?) JPEGReadWriter2 to something better.

we should merge them ? I have no idea...I just send a warning to you.

Cheers

Mariano