Hi Ben,... snip ...
Interesting find.
> Table 7 makes and interesting assertion that static types are more important
> for readability than preventing bugs.
This one is in line with Dan Luu meta-study that static typing catches
at best a small proportion of bugs.
Note that this is used in Smalltalk, when you write anInteger, aString
: you're using a form of typing for documentation.
By the way, I wrote for fun a small metalink-based run-time
type-checker using method argument names. To be used when running unit
tests :)
Regards,
Thierry