rowCount sounds like its the total number of rows.
rowNumber sounds like a particular row.

On Wed, Feb 11, 2015 at 12:12 AM, Johann Hibschman <johannh@gmail.com> wrote:
rowCount is better. "count" clearly refers to the cardinality. "number" in post-fix, like "rowNumber", sounds more like an ordinal, closer to "rowIndex", at least to my ears. "numberOfRows" is once again clearly cardinal, not ordinal, but it's longer.

Cheers,
Johann

On Mon, Feb 9, 2015 at 4:24 PM, stepharo <stepharo@free.fr> wrote:
thank chris.

I can tell you that I would be even more productive if I would be a native speaker....
So should we use rowCount for method argument?
because we got rows: rows meaning rows: rowCount and I rewrote them as rows: rowNumber but it could be better to have
rows: rowCount.

tx
Stef

Le 9/2/15 22:11, Chris Muller a ��crit :

On Mon, Feb 9, 2015 at 3:05 PM, stepharo <stepharo@free.fr> wrote:
Hi

a matrix has rowCount and columnCount and I was wondering if this api is the
way to get
the number of columns and rows of a matrix.
Would rowNumber and columnNumber be better?
I think rowCount is better than rowNumber for that.

You used "number of rows" in your own English right there, so
"numberOfRows" would be just as descriptive as rowCount, but not
better and certainly not worth changing the API, IMO.