I don't think we should come up with a new naming scheme every now and then. If I look at the read-only support there the selector is

beReadOnlyObject

so in this case it should be

bePinnedObject

I didn't like the extra Object at the end but now I think it makes it clear and still steps aside for user code to implement something like pin/unpin/bePinned

Norbert



Am 11.09.2017 um 11:56 schrieb Denis Kudriashov <dionisiydk@gmail.com>:

Anybody else?

2017-08-31 10:29 GMT+02:00 Pavel Krivanek <pavel.krivanek@gmail.com>:


2017-08-31 10:24 GMT+02:00 Denis Kudriashov <dionisiydk@gmail.com>:
Hi.

We now have very generic message names:
- pin
- unpin
- setPinned:
- isPinned

Problem that they collide with possible domain related names. 
For example I implemented pinning of tabs in Calypso and I found that I overrides #pin and #isPinned messages. Then I fix it with different names.
Probably menus also uses pin word but without overrides

What you think about renaming pinning messages? Something like:
- pinMemory

I would use pinInMemory

-- Pavel
 
- unpinMemory
- isMemoryPinned
- setPinnedMemory:
- pinMemoryDuring: (if we will introduce it)

I think it is easy to do now because not much code uses pinning