On 18 juin 2013, at 17:04, Cl�ment Bera wrote:
I don't like this new structure. Then people coming from non object language using all the time control structure will do :
#someRandomObject if: then: else: thinking of doing a C style condition and not using at all the receiver.
Come on, people are not that stupid !
And if they really are, no matter what you do, they will write bad code eventually.
It is not about replacing stuff, just adding one method. ifTrue:ifFalse: is still the better choice in most situations.