> On 5 Nov 2017, at 06:00, Stephane Ducasse <stepharo.self@gmail.com> wrote:
>
> Hi guys
>
> Why do we rename class Sort to introduce terms that have unknown,
> unclear, undocumented meaning?
+1
>
> To me PluggableSortFunction is MUCH better than CollatorBlockFunction.
but pluggable is also bad, IMO.
also I see there is some incoherence in the names:
ChainedSortFunction -> this is kind of ok, but I think a ���ComposedSortFunction��� is better.
SortByPropertyFunction -> shouldn���t be ���PropertySortFunction����� ? (coherent with the previous one)
CollatorSortFunction -> this is like a ���BlockSortFunction��� or ���ValuableSortFunction��� ?
Esteban
>
> Stef
>