Historically, it's always been 'initalize-release'


 
-----------------
Beno��t St-Jean
Yahoo! Messenger: bstjean
Twitter: @BenLeChialeux
Pinterest: benoitstjean
Instagram: Chef_Benito
IRC: lamneth
Blogue: endormitoire.wordpress.com
"A standpoint is an intellectual horizon of radius zero".  (A. Einstein)



From: Norbert Hartl <norbert@hartl.name>
To: Pharo Dev <pharo-dev@lists.pharo.org>
Sent: Saturday, January 13, 2018 6:33 AM
Subject: [Pharo-dev] Protocol names convention

I���m not the biggest fan of method categories/protocols but I try to.
What strikes me is the huge mess in names we have. Everytime I create e.g. an initialize method I���m asking myself which is the proper name to choose

initialize
initializing
initialization
���.

Do we have a convention for this?

Right now all names starting with init are

initialization-data
initialize-destroy
initialization-filter
initialize - release
initialize
initialization-union
initialize - event
initializing
initialization
initalize-release
initailize-release
initialization widgets
initalize
initialize-release
initialization-release

Norbert