#bindedXXX and #boundXXX sounds pretty static to me... It's like it was already binded. And maybe in the back it is dynamically looked up. Maybe a more abstract name can fit better:
#resolveToClass ? #lookupClass ?
Also (I'm pretty negative today), let's do not forget about traits! (We always do, and that gives us problems later )