Hi Torsten,Your summary is almost correct and indeed it shows a misunderstanding. Here the corrections from my point of view:- <gtExample> together with concrete usages and the associated mechanism was developed 1 year ago and it got integrated together with the rest of the GT from the beginning. <gtExample> has always meant a method that returned an object of the same class (or possibly subclass).- Like you pointed out, we renamed it to <example> after a discussion on this mailing list. You did not see the discussion. Or maybe it was not well explained, like Nicolai pointed out, even though the messages did show both concrete examples and the interpretation in tools.- Then a couple of weeks later you introduced the handling of #example* selectors in Nautilus.- Then I urged you to use the existing <example> instead of #example*, and the message was intended to mean that the <example> would have the meaning of the existing <example> annotated methods and their existing interpretation in tools and tests. This was my expectation, but it was likely not well explained.- You replied with a suggestion of adding the <example> check in the isExampleMethod, and I did not reply. If I would have seen that mail I would have not agreed.- You went on to add the <example> check resulting in fact in redefining the meaning of the original <gtExample>. I missed this change, too.So, I think this is the root of the misunderstanding.Now, the main disagreement is related to names. We would like to enhance significantly more the infrastructure around the gtExample in GT (including documentation, prototyping and testing), and I will try to summarize our thoughts in a post these days so that you can see the direction. In the meantime, I propose to have this discussion when we have more to show for in order to provide a more concrete point of view. This should happen after Pharo 4.And, to have a better chance of having a clean slate discussion later on in which to consider the value we associate to names, I would like to remove the <example> check from isExampleMethod and continue to preserve the treatment of #example* selectors in Nautilus.��That will reset the state as it was before hte above mentioned misunderstanding, and would allow us to start from scratch. Would you agree?Cheers,Doru