On 19 Mar 2019, at 09:50, Guillermo Polito <guillermopolito@gmail.com> wrote:YES!On Mon, Mar 18, 2019 at 11:13 PM ducasse <stepharo@netcourrier.com> wrote:Yes I had to rename ComposableModel into ComposablePresenter so this is probably thatOn 18 Mar 2019, at 23:09, Peter Uhnak <i.uhnak@gmail.com> wrote:Thanks Stef!The build is failing for Pharo 6.1 for some reason (I can't reproduce it locally), but I can look at that during the weekend...PeterOn Mon, Mar 18, 2019 at 9:23 PM ducasse <stepharo@netcourrier.com> wrote:AlexHave a look at the one I propose and play with it.Let me know what you think.StefOn 18 Mar 2019, at 21:20, Alexandre Bergel <alexandre.bergel@me.com> wrote:From: Alexandre Bergel <alexandre.bergel@me.com>Subject: Re: [Pharo-dev] About a better filedialogDate: 18 March 2019 at 21:20:35 CETTo: Pharo Development List <pharo-dev@lists.pharo.org>
I do not have time to personally work on this. But yes, having a better file dialog would be fantastic
AlexandreOn Mar 18, 2019, at 4:31 PM, ducasse <stepharo@netcourrier.com> wrote:
Hi guys
I did a pass (ported to P7, tonel, some little fixes) on the file-dialog developed by Peter Uhnak and I think that it would be good to propose it by default in the image.
what do you think?
https://github.com/Ducasse/file-dialog
I would also like that the filedialog remembers the last list of visited directory. (I will see if I can add this).
When Spec2 is out I would like to port it to Spec2.
Does anybody want to help? Because it would be super nice and I���m full with cleaning textEditor and pluggableTextMorph.
Stef--
Guille PolitoResearch Engineer
Centre de Recherche en Informatique, Signal et Automatique de LilleCRIStAL - UMR 9189French National Center for Scientific Research - http://www.cnrs.frPhone: +33 06 52 70 66 13