Hi,

I am working on making changes to FileSystemGs to make it work in Gemstone.

Who is or the the persons to talk to about changes on the Pharo side.

Areas of exploration to date have been:
  1. Replacement of File with GsFile - in Gemstone we want to use the native file class.
  2. Introduction of a FileMode class hierarchy to replace the passing of they symbols #read and #write.

FileMode 
FileAppendMode
FileAppendAndReadMode
FileAppendAndReadBinaryMode
FileAppendBinaryMode
FileReadMode
FileReadBinaryMode
FileReadWriteMode
FileReadWriteMode
FileReadWriteBinaryMode
FileReadWriteTruncatedMode
FileReadWriteTruncatedBinaryMode
FileWriteMode
FileWriteBinaryMode

Exiting format:
(filesystem open: aFileReference path writable: #write

Proposed format:
(filesystem open: aFileReference path writable: self store readWriteTruncatedMode

The #readWriteTruncatedMode method would return an instance of FileReadWriteTruncatedMode

If a form of this proposal were to be adopted, then the appropriate methods should be renamed to have mode.
As an example, #open:writeable:  would become #open:mode:

Thanks for your help.

Reg