P.S. regardless.. about the subject, so, now
Here's an example
nil asValueHoldershall be refactored tonil asReactiveVariable
?sounds like a plan :)====And yes, Ben, you are wrong, if you consider this as a personal attack.This code smells, to say it politely. But i prefer to call it crap.When i see such things, the only thing, which comes to my mind is: 'when the only tool you have is a hammer, you tend to treat everything as nail'.