I would use

TextModelCore
TextModelExtensions

TextModelCore-Tests

No extra dash in the middle. 
Stef

On May 21, 2013, at 10:24 PM, Denis Kudriashov <dionisiydk@gmail.com> wrote:

2013/5/21 stephane ducasse <stephane.ducasse@free.fr>

On May 21, 2013, at 9:00 AM, Denis Kudriashov <dionisiydk@gmail.com> wrote:

2013/5/20 stephane ducasse <stephane.ducasse@free.fr>

Hello.

New TxText version 0.8 is ready:

- editor stuff extracted to separate packages TxText-Editor and TxTextTests-Editor
may be you should call the second package TxTextEditor-Tests

I just follow convention of other TxText packages: TxText-Model -> TxTextTests-Model, TxText-Layout -> TxTextTests-Layout and etc.
Some times ago I suggest such repackaging and nobody was against it

Still I think that the packages names are not good. I do not hitnk that having tests mixed with the package name is a good approach
and we should clean all of them for 3.0

So what the correct way (Pharo way) to name test packages?
For example I have 'MyPackage-SubCat1-SubCat2'. What name for test package should be?
 

Stef