Just the English does not sound quite well for statements like:
�� �� �� �� mock should got someMessage
�� �� �� �� mock should not got anotherMessage.
I know that there was a long discussion about naming these. I do not remember the outcome, but still I think other alternatives would be better:
�� �� �� �� mock should haveReceived someMessage.
�� �� �� �� mock should not haveReceived anotherMessage.
or even
�� �� �� �� mock shouldnt haveReceived anotherMessage.
I think I would favor:
�� �� �� �� mock stub someMessage toReturn: 1000.
or
�� �� �� �� mock stub someMessage returns: 1000.
What do you think?