but this is not real immutability, is like a write barrier, that���s why those method names were not chosen. 

Esteban

On 25 Jan 2017, at 12:37, phil@highoctane.be wrote:

So, beImmutable and beMutable seem pretty usable and not collision causing IMHO.

Phil

On Wed, Jan 25, 2017 at 12:19 PM, Norbert Hartl <norbert@hartl.name> wrote:

Am 25.01.2017 um 12:16 schrieb Esteban Lorenzano <estebanlm@gmail.com>:


On 25 Jan 2017, at 12:04, Denis Kudriashov <dionisiydk@gmail.com> wrote:


2017-01-25 12:03 GMT+01:00 Denis Kudriashov <dionisiydk@gmail.com>:
I think problem that these names could be already in use by frameworks. I am sure #isReadOnly, #beReadOnly is used in many UI's. For example Margitte uses it 

And probably Glorp

yes, but #setIsReadOnlyObject: deserves a place in the podium of ugly names :)

Absolutely. And we are a really caring community because we care so much about a method name of a feature that does not work :)

Norbert
I thought the names were going to be like beWritable/beNotWritable/isWritable
which are not a lot better, but well��� 

Esteban